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WelcomeWelcomeWelcomeWelcome
Welcome to Web Page Editors: A Hands-On Introduction to Netscape Composer.
This class will introduce you to the world of creating web pages using a
specialized program available to you with your Netscape browser. We have
selected to teach Netscape Composer for two reasons.  First, it is easy to use
especially for beginning web designers and second, Composer is a free program
that is part of the Netscape Communicator suite.

Why Use the Web?Why Use the Web?Why Use the Web?Why Use the Web?
Many educators wonder why they would want to use the web as a medium for
storing and presenting information. Here are some points to ponder when
deciding if the web is a worthwhile medium for you and your classroom:

•  The web runs 24 hrs a day.  Students, parents, and other educators
can access your information any time.

•  The web has worldwide access.  A parent or student can find out about
class activities, homework assignments or read lecture materials from
anywhere they have access to the Internet.

•  The web makes your presentations instantly portable.  You can access
lecture notes from any computer either in your classroom or at a
conference across the state or around the world.

•  Information is one of the most valuable commodities we have to share
today. The Web allows you to gain access to that commodity.

Even when you understand the Web is a valuable tool there are still concerns
about how to use it in the classroom.  UEN offers many classes on how to
integrate the Internet in to your curriculum but in this class we are going to focus
on how to create you own web site of information that can be shared over the
Internet.  You many be thinking “isn’t it hard to make a web page?” or “doesn’t it
take a lot of time to create a web page?”.  By the end of this class, you will
realize that anyone can create a web page.

Web DefinitionsWeb DefinitionsWeb DefinitionsWeb Definitions
Here are some handy definitions that will help you better understand what
happens when you create a web page.

Web Page Editors
Introduction
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HTML – Hypertext Markup Language is a text formatting language that is used to
create web pages.  HTML consists of tags that are used to tell the web browser
(Netscape Navigator or Microsoft Internet Explorer) how to display the
information on your computer screen.

Note: Although it is not necessary to know HTML to create a
web page, we highly recommend that you learn how to write
HTML code.  If you don’t take the time to learn HTML you will
always be at the mercy of the software you use to create the
site.  UEN offers several HTML classes.

Web Page – A single file made up of text and HTML code (Also called an HTML
Document).  A web page is saved with a .html or .htm extension (index.html).

Web Site – A collection of web pages that make up a specific collection of
information. Web pages the make up a web site are usually stored in the same
folder on one computer.  Very seldom will you ever make just one web page
most likely you will make a web site.

Web Server – A computer with a constant connection to the Internet that stores
the pages that make up your web site.  To make your web site available to the
WWW you must have your pages on a web server.

Home Page – The first page or “home base” page of your web site. The home
page is usually the “welcome” page.  It is a good idea to always save your home
page with the name index.html.

Hypertext/Hyperlink – Text or graphic that when clicked on will take you to
another web page.  Hypertext and hyperlinks are what make the web such a
useful tool.

WWW - World Wide Web

URL - Uniform Resource Locator an electronic address for the web page.

Web pages or HTML documents are nothing more than text.  To create a web
page by hand all you need is a text editor like Notepad (Windows) or Simple Text
(Mac) and a collection of images to put in the page.  Creating web pages by hand
can be a very time consuming task depending on how large your web site is.
Web Editors were developed to save web designers time as well as make it
easier for anyone to make a web page.

Web Editors are “word processors” for web documents.  They give you the ability
to create a web page without being ‘bogged down’ in the code.  Editors increase
efficiency and simplify many of the processes used in creating a good web site.
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However, to be a true webmaster or web designer requires an understanding of
HTML and the support of a good editor to help you accomplish your goals.

There are dozens of web editors available on the market of differing costs,
complexities and abilities.  In this class, we will concentrate on learning to use
Netscape Composer. Netscape Composer is not the most powerful web editor
around but it is easy-to-use and the price is right (free), making it a perfect tool to
use for beginning web designer.
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CAN CAN CAN CAN I MAKE A WEB PAGE?I MAKE A WEB PAGE?I MAKE A WEB PAGE?I MAKE A WEB PAGE?
The real question is not if I can make a web page, but should I make a web
page?  Anyone with a little desire can build a web page.  The process is no more
difficult than creating a newsletter or putting together a “PowerPoint”
presentation.  The difference is the medium used to present the information and
the potential audience that you can reach with your web page.

There is only one rule you should apply to creating a web page. Make sure that
there is a purpose for putting information on the web.  Ask yourself, “will my web
page add to the wealth of knowledge available on the web and/or provide a
valuable resource to a community I interact with.” No one likes to look at a page
that just says Hi.  If the information you are going to provide is already on the
web there is no need to completely duplicate the information.  However,
providing a collecting point for information pertinent to your classroom or school
is a beneficial use of the web.

PlanningPlanningPlanningPlanning
Before you sit down at a computer to make your web site, you should plan it on
paper first.  Decide on the purpose of your web site, make a list of the items you
want to include on your site.  Sketch out the layout of each page and show how
they link together.  Gather the resources you need, text, graphics etc.

Planning includes more than just the layout of the site.  A good site also has a
consistent look and an orderly method of presenting information.  Before the first
<HTML> tags or images are put on a page, a true webmaster will have a strategy
for the site about to be created.

The Look
The look of the page should be consistent.  Use the same background,
color scheme, font, and header/footer style.  Pages that change design
from page to page may show off your design ability but the viewer will
have a hard time knowing if he/she has left your site or is still accessing
the intended information.

Section 1
Planning Your Web Site
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Consistency applies too more than your current pages.  As you update
and maintain the site, try to maintain the look of your site.  Web pages are
a lot like magazines.  When people choose to subscribe to a magazine,
they often have a choice between several on the topic.  Subscription is
based as much on the layout as on the content.  A layout change can
have a drastic affect on readership.  If you are going to change the look of
your site, publicize it and helping people get adjusted to it.

The Information
Present the information in tidy packages.  Too much information on the
screen is very difficult to read and inconsistencies in the presentation style
will cause confusion.  Some designers recommend a 3 x 3 rule for their
pages.  No more than three paragraphs of three sentence each per page.
This will assure plenty of "white space" on the page.

Navigation
Navigation is a critical issue.  A good web site has a structure that is easy
to follow.  When designing your site create a flow chart that represents the
pages and how they will be interconnected.  Buttons that let the guest
return to your homepage are essential.  Sometimes people will access a
web site from somewhere other than the homepage.  If you don't provide
good navigation, people browsing your site won't get to see all of your
handiwork.

Production
This is the fun part of web creation.  Now that you have made the effort to create
a plan, it is time to see if the plan is a good one.  Some points to remember when
creating your page:

•  Don’t over decorate your page.
•  Avoid long text sections.
•  Don't use busy backgrounds.
•  Keep image sizes small.
•  Check your spelling.
•  Split long pages into several shorter ones.
•  Use lists to avoid long text sections.
•  If you use a graphic for navigation provide text links as well.
•  Design for your target audience.
•  Stick to the established web standards. http://www.w3c.org/

Validating
Validating your page is a good final measure before you let the world see
your site.  Web page validation is like giving your page to a proofreader to
look for subtle grammatical errors.  HTML is a world wide standard and
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has very strict standards on how the code should be used.  Web browsers
are rather forgiving when it comes to minor infractions of the HTML code.
In order to ensure that your page will be viewed successfully around the
world, the little extra work of validating you code is worth it.  You can get
software to help with the validation process.  Many web page editors have
validators built into them.  Additionally web sites offer validation services
as well.  Below is a list of web site validators:

CAST: Bobby - http://www.cast.org/bobby/
Is your Web page accessible to people with disabilities?  Bobby
is a Web- based checker that will examine your page for
accessibility problems.

Doctor HTML - http://www2.imagiware.com/RxHTML/
Doctor HTML is a complete HTML checker.  It has spell checker,
some version validation, tables and forms checking, and link
verification.

WDG HTML Validator - http://www.htmlhelp.com/tools/validator/
The WDG Validator will check the syntactical correctness of your
HTML to help you produce more accessible Web pages.

Weblint - http://www.unipress.com/cgi-bin/WWWeblint
This is a more general HTML checker. It's output is friendlier
than the HTML validator and also checks for some of the more
common mistakes. Weblint now charges for its services at this
site. However you can submit documents of less than 2k for free.

PublishingPublishingPublishingPublishing
Once all the hard work of creating the page is complete, it's time to get the page
on a server and let people see your work.  This can be accomplished many
different ways.  One is “word of mouth.”  In the case of a school site this may be
enough.

If you really want to get your site out there then you should register with the
various search engines on the web.  Lycos, Yahoo, Excite and Web Crawler all
have registration opportunities.  This can be a slightly time consuming process,
but it will ensure that you get into the search engine databases.  The easier
alternative is to use the services of Submit It!  Submit It! (www.submit-it.com/) is
a web site publicity service that relays information to all of the major search
engines for a modest fee.  When registering your site remember to give a good
description of your site using keywords that people are likely to use when
searching for a site like yours.

http://www.cast.org/bobby/
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The last alternative is to use the lazy persons method, that is to wait for the
search engine spiders to come crawling through your site.  This method doesn't
typically produce as many hits unless you have used the <META> tag effectively,
titled your pages to produce hits or are just plain lucky.  The <META> tag is
introduced in UEN Staff Development  “Advanced HTML” class.  The size of the
audience you want to collect will determine which alternative you will use.

Hosting A Web SiteHosting A Web SiteHosting A Web SiteHosting A Web Site
Creating a web page doesn’t require any particularly sophisticated equipment.  A
basic text editor and a web browser are the only tools that are a necessity.  On
the other side of this coin is the hosting of a web page.  Hosting or publishing a
web page requires the use of more sophisticated resources, specifically a web
server and an Internet connection.  This section discusses various ways of
finding a home for your web site and topics that you should be aware of when
publishing your web site.

A web server is a specialized computer that is set up to present HTML
documents to client machines that request the information.  Getting access to a
web server is not a particularly difficult obstacle to overcome.  Depending on the
nature of your site, the frequency of revision, size and other variables one of the
following solutions will allow you to get your site online.

District/School Hosting
One of the best resources to use as an educator is your district or school
web server.  To find out what resources are available to you check with
you Network Administrator.  There should be space available to you for
publishing a school or classroom web page.

Depending on how your district or school administers their web site, you
may be limited in some areas such as site size, access to the server, and
content on pages.  As you approach your district or school ask some
questions:

•  Will I have personal access to the server or will the
administrator be managing the file transfers?

•  Who else will have access to my web site?
•  Do I have a limit to the amount of information I can store on the

server?
•  What type of directory structure is preferred / required?
•  What is the default home page name if index.html is not used?
•  What MIME types are supported? Flash, Java, Microsoft,

VRML, Sound, Video?
•  Can I use “X” software with the server?
•  What will be the URL of my web site?
•  Can I use CGI scripts?
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Commercial Internet Service Providers (ISP)
Typically ISP’s are very easy to work with and very accessible, they do
however cost money for the account.  Commercial Internet providers
typically use UNIX machines for their servers.  This is a different platform
from Windows or Macintosh.  Working with these types of machines
requires familiarity with Telnet, FTP and a basic understanding of UNIX
permissions to take full advantage of the web hosting capabilities.

Many of the same types of questions apply when working with a
commercial ISP or web host.  However some things are different.

•  You will be responsible for posting your web pages.
•  Customer support may be more (or less) accessible.
•  Space limitations will apply.

If you have a commercial Internet account you are likely paying for a web
page whether you are using it or not.  Additionally you may find that your
ISP has more capabilities available for your web site than may be
available through District/School hosting. For instance:

•  Preformatted CGI scripts for form parsing.
•  Preformatted Guestbooks and hit counters.
•  Database Support (i.e. SQL, Access, Oracle)

Free HostingFree HostingFree HostingFree Hosting
Several web sites provide free web page hosting.  Of course, you may end
up with a URL that is extremely long we recommend reading the fine print
when using a free hosting service.  Here are a few site that provide free
web page hosting:

ACME City - www.acmecity.com/
B-City - www.bcity.com/bcity/
Conk!World - http://conk.com/world/
Geocities – www.geocities.com
FreeTown - http://www.freetown.com/
Homestead - http://www.homestead.com/

Self Serving
If the other three options won’t work, you can always set up your own web
server.  This is not a particularly difficult task, however many new
variables enter the picture as you shift from Web Master to Server
Administrator.  UEN offers Web Server class if you are interested in learn
how to set up your own web server.

http://www.acmecity.com/
http://www.bcity.com/bcity/
http://conk.com/world/
http://www.geocities.com/
http://www.freetown.com/
http://www.homestead.com/
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Take some time and plan your web site.  Decide its purpose and what
information you will include on it.  Draw the layout and navigation on paper.
Create a storyboard!

Now You Try It
Activity 1
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The following sections are designed to introduce you to the basic functions of
Netscape Composer, a web page editor that is part of both Netscape Navigator
(v3.0) and Netscape Communicator (v4.0).  Using this editor allows you to do
almost everything you need to do when creating a basic web page. You don’t
have to be a computer whiz – you can use Netscape Composer, to create, and
edit, your own web pages.

Netscape ComposerNetscape ComposerNetscape ComposerNetscape Composer
Composer helps you create and edit your own web pages.  Composer looks and
acts like a word processing program, and is just as easy to use. The basic
elements of a web page are text, pictures, and links; composer give you access
to all of these elements in a simple format.

Note:  Netscape Composer is the web page editor that comes
with Netscape Communicator Suite.  If you don’t have
Netscape Communicator or are using an older version, you
can download the latest version of Netscape’s browser free by
going to http://www.netscape.com/computing/download.

•  Netscape Communicator 4.7 – the newest version with the heaviest system
requirements.  The Windows 95/98/NT version requires a 486 processor and 32 MB
RAM; the Macintosh version requires a PowerPC processor, 24 MB Ram, and system
7.61/8.1 and higher.

•  Netscape Communicator 4.0 – an older version that works for Windows 95/NT and
even Windows 3.1; also OK for Macintosh 68K processors but still requires System
7.6

Setting up a File StructureSetting up a File StructureSetting up a File StructureSetting up a File Structure
Before you begin to create a web site, you should set up a file structure on your
computers hard drive.  This is the location on your computer where all of your
HTML documents and images for your web site are going to be saved.  It is very
important to save all of you web pages for your site in the same folder, by doing
so you will save yourself many headaches. For the purposes of this class, let’s
create a folder on the desktop.  Use the right mouse button (right click) on the
desktop, a pop-up menu will appear, select New and Folder.  A new folder will
appear on your desktop.  Give the folder a name such as “my web page” or “web

Section 2
Getting Started

http://www.netscape.com/computing/download
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site” or something as equally descriptive.  Open your new folder by double
clicking on it with your mouse.  Once the folder is open, create another new
folder.  Name this folder “images” or “graphics”.  You will save all of the graphics
that you use on your web pages in this folder.  The purpose for creating a
graphics folder is to help keep your folder organized and easy to maintain.  There
is no set rule has to how your file structure should be set up inside of the web site
folder.  Do what ever is most logical to you.

How to Start ComposerHow to Start ComposerHow to Start ComposerHow to Start Composer
To begin creating a web page, open Netscape Navigator (the browser).  When
you create a web page, you will need BOTH Netscape Navigator and Netscape
Composer.  You will create your web page in Composer and then view the
results in Navigator.  Look at the lower right-hand corner of the Netscape
Navigator screen.  You should see a small toolbar that looks like this:

On the left is the wheel symbol for Navigator (browser).  On the right is the
pen and pad           symbol for Composer.  When you click on the compser
symbol Composer will be launched opening to a blank page.  You can move from
Composer to Navigator simply by clicking on the appropriate symbol.

Two other ways to start Composer are:
1. Go to the File menu, select New, and Blank page.
2. Go to the Communicator menu and select Composer.

This is what Netscape Composer looks like when it is open:

Pull Down Menu

Composition Toolbar

Formatting Toolbar

Document Window
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Netscape Composer has three major tool bars:

Pull Down Menu - is at the top of the screen at all times.  Click on one of the
words in the menu and a Pull down menu will appear.

Composition Toolbar – this toolbar contains shortcuts to the most commonly
used functions in Composer.  If you would like to hide the Composition Toolbar
pull down the View menu and select Show Composition Bar.  If you would like
to bring the toolbar back, repeat the above step.

Formatting Toolbar – this toolbar contains shortcuts to the most commonly
used formatting command used when creating a web page. This toolbar is very
similar to the formatting toolbars in a word processor.  If you would like to hide
the formatting toolbar pull down the View menu and select Show Formatting
Bar.  If you would like to bring the toolbar back, repeat the above step.

Review the BasicsReview the BasicsReview the BasicsReview the Basics
Many of the techniques you use in your word processor will also work the same
way in Netscape Composer.  Perhaps the most useful of these are the cut, copy
paste, undo, and save functions.

TO CUT: Highlight the item you want to move.  (Remember, "cut" will take
something such as text or an image, remove it from where it is and place it
somewhere else).  Then click once on the "cut" icon at the top of the page.

TO PASTE: Click your cursor once on the page where you want to put
what you just cut.  Then click on the "paste" icon at the top of the page.
Bingo!  It magically reappears in its new location.

TO COPY: Same procedure.  Highlight the section you want to copy, then
click on the "Copy" icon at the top of the page. When you copy, you will
make a second version that you will then insert in a new location, leaving
the original where it is.  To paste the second version, see instructions
above.

SPELL CHECK: Place your cursor at the beginning of the page then click
the Spelling Button.  A suggestion list will appear for each misspelled
world.

TO UNDO: If you try something and don’t like it, you can use the "undo"
feature to get rid of it.  Go to the Edit drop-down menu at the top of the
screen and Select Undo.  However, you must invoke this command
immediately after the goof.  "Undo" will only undo the last operation.
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TO SAVE: As you work on your web page, do a little bit at a time, and
save often by clicking on the save icon.  Each time you add to your web
page in Composer, then switch to Navigator to view it, you will need to
click on the RELOAD icon in Navigator to view the changes.
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Complete the following step.

1. Create a folder on the desktop of your computer.  Name the folder
“your name” or “web folder”.  This is the folder were you will save all of
your work.

2.  Open Netscape and practice going between Netscape Navigator and
Netscape Communicator.  Practice until you feel comfortable going
between the two programs.

3. In Netscape Composer, become familiar with the interface by looking
in the pull down menus and clicking on some of the buttons.

Now You Try It
Activity 2
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The easiest way to learn how to make a web page is to make one and then
experiment with it.  The following are step by step instructions on how to create
your own web page using Composer.  There are many web sites tutorials on how
to use Netscape Composer.  The step by step instructions for this manual are a
combination of few of the following web site tutorials.

•  www.msubillings.edu/tool/tutorial
•  admin5.hsc.uth.tmc.edu/ishome/applications/composer/wbt/index.htm
•  www.oxy.edu/departments/intech/how-to/publishing.html
•  WWW.CS.Trinity.Edu/~thicks/Communicator/Composer1/
•  www.furman.edu/~pecoy/mfl195/composer/

Creating a New Page

1. Start Composer.

2. Composer will launch with a new, blank web page in the window.  This
new page is your blank canvas for composing a web page, hence the
name Composer!

3. If you would like to create another blank page while in Composer, you
can do it one of two ways.

•  Go to the File menu, select New, and Blank page.
•  Click the New button on the Composition toolbar.

Select Blank Page button from the pop-up menu.

Section 3
Setting up a Web Page

http://www.msubillings.edu/tool/tutorial
http://www.oxy.edu/departments/intech/how-to/publishing.html
http://www.cs.trinity.edu/~thicks/Communicator/Composer1/
http://www.furman.edu/~pecoy/mfl195/composer/
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Setting Page PropertiesSetting Page PropertiesSetting Page PropertiesSetting Page Properties
Begin your web page by setting up the basic characteristics for the page.  Such
as background text color, page title etc.

1. Go to the pull down menu Format > Page Colors and Properties.  A
pop dialog box will appear select the General tab.

2. Type a title for your web page in the title text box.

Note: The title is displays at the top of the screen when
you view the page in a web browser.  Enter a
descriptive, user-friendly title.  (if you don’t do it at this
point, you will be prompted to do it later).

3. Enter your name or email address in the author text box.

4. Type a description for your page in the Description text box.  Make the
description short and accurate.  This description is used by search
engines to describe your page.

5. Type in some keywords in the keyword text box.  Use keywords that
you think people will use at a search site to find your page.
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6. Click the Colors and Background tab.

7. Select the radio button next to “Use custom colors”.  You can change
the text, links, and background color for your page by clicking on the
color box and selecting the desired color from the palette.

Note: Netscape provides color schemes to choose
from.  White or subtly colored backgrounds work best.
If you use a dark color, make sure that you have
contrasting text colors.

8. If you have a background image that you would like to use for your
page, put a check mark next to “Use Image:” and click the Chose
File… button.  Your background image should be saved in your web
folder.

9. If you want to use these page settings on all of your pages that your
are creating for your web site check the box next to “Save these setting
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for new pages.”  Every time you create a new page in Composer it will
have these page settings and colors.

10.  Click the OK button when finished.

Saving Your PageSaving Your PageSaving Your PageSaving Your Page
Before you get too far on your web page, you should save it.  This will ensure
that if you computer crashes you will now lose everything.  It also establishes the
location of the file, which is important when you are adding graphics and creating
hyperlinks.

1. To save your page go to the pull down menu File > Save or click the
Save button on the Composition toolbar.

2. In the save as dialog box find the location of you web folder and give
your page a file name i.e. index.html or class.html.

Note: Avoid using spaces or special symbols in your
file name.  If this is the very fist page of your web site,
use the name index.html.  Any other page can have
whatever name you want to give it.  Make sure that you
save often!

Previewing Your PagePreviewing Your PagePreviewing Your PagePreviewing Your Page
You can preview your document at any time while you are working on it.  It is
recommended that you preview your page often because what you see in the
document window in composer is not always what it will look like in the browser.
It is especially important that you preview your web pages before you put them
on to the Internet.  Make sure that your page formatting looks good, all of you
image appear and all of you links work.

1. If you haven’t already done so, save the page you’re working on by
clicking on the Save button on the Composition toolbar.

Note: Always save your page before you preview it.  If
you do not save the changes you made since the last
save will not be displayed.

2. From the composition toolbar, click the Preview button.
Your web page will open in Netscape Navigator and
display as others would on the web.
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Complete the following steps.

1. Create a blank web page.

2. Set up the page properties for your web page.  Give it a page title,  set
up the color scheme and background color or image.

3. Save you web page in you desktop folder.

4. Preview you page.

Now You Try It
Activity 3
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Adding and Formatting TextAdding and Formatting TextAdding and Formatting TextAdding and Formatting Text
Adding text to you page is very similar to adding text in a word processor.

1. In the document window, click to place your cursor in the window.
Your cursor will appear in the top left corner of the page.

2. Start typing.

Now that you have text on your page, you can change the formatting.

3. Select the text you would like to format.

Section 4
Working with Text
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4. Change the font for the selected text by going to the pull down menu
Format > Font.  Or select a font from the font pull down menu on the
Formatting Toolbar.

5. Change the font size for the selected text by going to the pull down
menu Format > Size.  Or select a size from the Size pull down menu
on the Formatting Toolbar.

6. Change the font Style for the selected text by going to the pull down
menu Format > Style.  Or select a Style from the Formatting Toolbar.
You have a choice of Bold, Italic, Underline, or No Style.
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7. Change the font color for the selected text by going to the pull down
menu Format > Color.  Or select a color from the color pull down
palette on the Formatting Toolbar.

8. Change the alignment for the selected text by going to the pull down
menu Format > Align.  Or select an alignment from the alignment pull
down icon on the Formatting Toolbar.  You have a choice of Left,
Center, or Right alignments.

9. Indent the selected text by going to the pull down menu Format >
Increase Indent.  Or click on the increase indent icon on the
Formatting Toolbar.

10.  To create a number or bulleted list go to the pull down menu Format >
list and select the type of list you want to create.  Or select either the
number or bullet list icon from the Formatting Toolbar.

Note: When using a number list you will only see #
where the numbers should be.  When you preview the
page in Navigator the numbers will appear correctly.
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Add a Horizontal LineAdd a Horizontal LineAdd a Horizontal LineAdd a Horizontal Line
Horizontal lines are a good way to break up sections of text or divide the space
on your page.

1. Click the location in the Composer window where you want to insert
the line.

2. Go to the pull down menu Insert > Horizontal Line or click the Insert
Horizontal Line button on the Composition toolbar.  A line will
appear on you page.

3. Double click the line to change its size or style.  The horizontal Line
                Properties dialog box will appear.

4. Set the properties the way you would like line to appear.

5. When you’re done click OK to close the Horizontal Line Properties
dialog box.
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Add text to your web page.  Use some of the formatting tools available in
Composer.  Use a couple different styles and colors.

Now You Try It
Activity 4
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Graphics for the WebGraphics for the WebGraphics for the WebGraphics for the Web
You can put images on your pages to make them more visually interesting.
Images are part of why the web is so popular.

Each image on a web page is a separate file, distinct from the HTML document
that makes up a web page.  The page contains not the images themselves, but a
link to the image, which is displayed as part of the page.  It is very important to
save you images your web folder.  When you publish your pages on the Internet
both the pages and the images must be placed on the web server.

File Formats for the Web
There are two graphics formats that are used on the web: GIF and JPEG.
GIF’ s are usually the best format for graphics with a few solid colors, such
as logos.  GIF files end with the extension .gif.  JPEG’s are the best for
graphics with many colors such as photographs.  JPEG files end with the
extension .jpg.

Where can I get graphics?
There are several ways to obtain graphic for your web page.

1. From other web sites: Right-click on a picture and the option to save
it will usually appear on the shortcut menu ("Save Image As" or "Save
Picture As").  Save it in the folder you have created for web page files.

Note: When you are considering using other people's
graphics, always assume they are copyrighted unless
otherwise noted.  There are several free clipart sites on
the web try to stick with them.  If you are using a graphic
from someone else’s page, ask permission first.

Here is some web sites that offer free graphics (unless otherwise noted on
the site):

Barry's Clip Art Server:  www.barrysclipart.com
Clip Art Connection: www.clipartconnection.com
Search Altavista:  www.altavista.com

Section 5
Working with Images

http://www.barrysclipart.com/
http://www.clipartconnection.com/
http://www.altavista.com/
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2. Scan them: Some schools have scanners available that convert
photos to computer graphics.  To learn more about scanning photos
take the UEN’s Web imaging I class.

3. Digital Camera: If you have access to a digital camera you can take
pictures and they are saved in the digital format.  Check the setting of
you camera and make sure that the pictures are saved as .jpg.

4. Convert existing graphics: If you have access to Graphics Editor
Program, you may be able to open and save an existing graphic in the
GIF or JPEG format.

Now that you know how to obtain graphics lets put them on your web page.  Just
make sure that the graphics that you are going to use are saved in you web
folder.

Placing ImagesPlacing ImagesPlacing ImagesPlacing Images

1. Click the place in the document window where you want the image to
appear.

2. From the pull down menu Insert > Image or click the image button
on the Composition toolbar.  Either way, the Image Properties
dialog box will appear with the Image tab visible.
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3. Click the Choose File… button on open dialog box will appear.  Locate
the Image file on your hard drive and click Open.  The Open dialog box
will close.  You’ll see the path and name of the image file you selected
in the Image Location text box.

Note: By default, Composer saves a copy of the
image in the same folder has the page so that
images will always appear with your web page.  If
you move the image file to a different folder, it will no
longer appear on your page.

4. You can set several other properties for you images experiment with
them and see how they affect your page and image.

5. When you’re done, click OK to close the Image Properties dialog box
and return to the Composer window, where you’ll see the image on the
page.

6. If you would like to align you image select it and go to the pull down
menu Format > Align.

Note: You can make the image bigger or smaller by
selecting it and then clicking and dragging the image
from the corner.  However, this will sometimes
distort the image or make it look pixely.
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Add some graphic to your page.  If you need to take some time and find graphic
on the Internet that you can use.  Make sure that you save all graphics you want
to use on you web page in your desktop folder.

Now You Try It
Activity 5
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Creating LinksCreating LinksCreating LinksCreating Links
A link, also know as a hyperlink, is what distinguishes web pages from plain old
pages.  Clicking a link takes a web user to another web page.  A link is simply the
address of the other web page.  Both text and graphics can be hyperlinks.

There are two types of links: internal (or relative), external (or absolute).  Use
internal links to connect files within the web site you are creating.  Use external
links to connect to other web pages outside of your web site.

In the example below, the pages index.htm and resume.htm are being created by
the same person.  The links are internal.  The School of Hard Knocks web site is
an external link.

There are two special links, an email link and a target link.  You can use the
email links to send email from your page.  Use a target link to link to information
with in the same page.  Let’s go ahead and create some links.

Text LinkText LinkText LinkText Link

1. In the Composer window, select the text that you want to become a
link.

Section 6
Creating Links



39

2. Go to the pull down menu Insert > Link or click the Link button on the
Composition toolbar.  The Character Properties dialog box will appear,
with the Link tab at the front.

3. If you are linking to an external source type (or paste) the URL of the
page to which you want to link in the Link to text box.  Make sure that
you address starts with an HTTP:// your link will now work with out it.

4. If you are creating an internal link, click the Choose File… button and
browse to location of the internal page.  The page you are linking to
should be in the same web folder.

5. Click OK to close the Character Properties dialog box and return to the
Composer window.

Note: An email link allows the reader to send you an
email message directly from your web page.  To create
an email link simply follow the above steps and instead
entering the web page URL in the link to text box type
Mailto:name@someware.com.  (Do not add any
spaces).  This will create an email link.

mailto:name@someware.com
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Image LinksImage LinksImage LinksImage Links

1. In the Composer window, select the image that you want to become a
link.

2. Go to the pull down menu Insert > Link or click the Link button on the
Composition toolbar.  The Image Properties dialog box will appear,
with the Link tab at the front.

3. If you are linking to an external source type (or paste) the URL of the
page to which you want to link in the Link to text box.  Make sure that
you address starts with an HTTP:// your link will now work with out it.

4. If you are creating an internal link, click the Choose File… button and
browse to location of the internal page.  The page you are linking to
should be in the same web folder.

5. Click OK to close the Image Properties dialog box and return to the
Composer window.
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Target LinkTarget LinkTarget LinkTarget Link
You would use a target link if you had a long web document such as the
Constitution of the United States and you wanted your readers to be able to jump
to certain parts of you document i.e. Article III.  Section 2.  Then you would use a
target link.

1. Create a table of content or some type of text navigation at the
beginning of your document.

2. Place your cursor in front of the text in your document that you would
like to jump to i.e. Article III.  Section 2.

3. Go to the pull down menu Insert > Target or click the Target button
on the Composition toolbar.  The Target Properties dialog box will
appear.

4. Give the target a name.  Make the name simple and easy to
understand.  Click OK when you are finished.

5. A target Icon will appear in front of the text you want to be able to jump
to from the beginning of the document.  This icon will not be visible
when viewing the page in Netscape Navigator.

6. Create the link to the target by selecting the text that you want the
readers to click on to get to the target.  This text will most likely be in a
table of contents, or text navigation at the top of the document.
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7. Click the link button and the character properties window will open.
Click the radio button next to “Current Page”.  All of the available
targets for that page will show up in the target window.

8. Select the target you want to link to from the target window.

9. Click OK when finished.

Removing or Changing LinksRemoving or Changing LinksRemoving or Changing LinksRemoving or Changing Links

1. To remove a link right click on the link and choose Remove Link from
the pop-up menu.
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2. To change a link right click on the link and choose Link Properties
from the pop-up menu.

3. To remove a target.  Select the target icon and press the delete key on
your keyboard.  Make sure that you remove any links to the target you
deleted.

4. To change a target double click on the target icon and the target
properties dialog box will appear.  Make sure that you change any links
to that target.
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Complete the following steps:

1. Create a text link to an internal page and an external page.

2. Create an image link.

3. Create an email link.

Now You Try It
Activity 6
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Tables help you organize and present information, such as a calendar of event,
faculty and staff information, or homework assignments for the year in a grid of
columns and rows.

You can also use one or more tables on a page when you want to have greater
control over the layout of you text and images. Alignment of text and images is a
serious problem in HTL documents.  Tabs don’t work in HTML as they do in word
processors.  You can’t use tabs to line up information in columns.  HTML only
recognizes on space from the space bar.  You can not set Margins in HTML
documents.  To solve these problems you will want to use tables.  They are very
easy to do with the table tool in Composer.

Create a TableCreate a TableCreate a TableCreate a Table

1. Click in your document window where you want the table to appear.

2. Got to the pull down menu Insert > Table or click the Insert Table
button from the Composition toolbar.  The New Table Properties
dialog box will appear.

Section 7
Working with Tables
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3. Set the number of rows and columns you want your table to have.  You
can always add more later.

4. Set the table alignment (right, left, center).

5. Set the border line width.  If you do not want a border around your
table change the border line width to 0.

6. Set cell spacing and cell padding.

7. Set the table width.  The table width can be either in % or in pixels.

Note: If you use % then your table will changes sized
depending on the browser window size.  If you use
pixels you table will always remain the same size.

8. Decide if you want your columns to be equal sizes or to adjust to the
content that is with in the cell.  Check the box if you want the columns
to be equal sizes.

9. If you want to have a background color for your table, check the box
and pick a color by clicking on the color box.

10.  When finished click OK.

11.  Once you have your table in composer you can add text in or insert
image in the cells.  Simply put your cursor in on of the cells and
proceed as you would outside of the table.  Any formating that you can
do outside of the table you can do inside of the table, such as changing
font size, color, style, aligment or making the text or image a link.
Below is an example of a table.
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Adding or Deleting Parts of the TableAdding or Deleting Parts of the TableAdding or Deleting Parts of the TableAdding or Deleting Parts of the Table

1. To add a row to the end of your table, put you cursor in the last cell
and press the tab key.  A new row will be added to your table.

2. To add a row in the middle of your table, put your cursor in the row
ABOVE were you want to add the row.  Click the right mouse button
and the following menu will appear.  Go to Insert > Row.

3. To add a column, place your cursor in the cell TO THE LEFT of where
you want the new column to appear.  Click the right mouse button and
got to Insert > Column.

4. To delete the table, column, row or cell put your cursor in the location
in the table you wish to delete and right click.  Select Delete > “item”
from the pop-up menu.

You can at anytime change the basic characteristics of your table.

1. Place you cursor with in the table, right click the mouse and the
following pop-up menu will appear.  Select Table Properties.
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2. The Table Properties window will appear with the table tab showing.
Change whatever properties are necessary and click OK when
finished.

3. You can change individual cell properties by clicking in the cell that you
want to change and right click and select Table Properties from the
pop-up menu.

4. Click the Cell tab in the Table Properties dialog box.
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5. If you would like a cell to span over multiple rows or columns change
the appropriate text box.  This is very helpful when you are trying to
create an appealing layout design using tables.

6. You can also change the color of individual cells.

7. Play around with the different options available in the Table Properties
dialog box.
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Create a table on you web page.  Use the table as a way to display information in
a grid of columns and rows or use it for layout purposes.

Now You Try It
Activity 7
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Publishing Your PagePublishing Your PagePublishing Your PagePublishing Your Page
If your page exists only on your local hard drive, you can browse the page, but no
one else can.  Once you have finished making your web page and have tested
the links, you need to publish your page to a Web Server.  When you publish
your page on a Web Server, you copy your page to a computer that lets other
people see it over the Internet.  You must have access to a Web Server, this
access may come from you school or district, a free Internet web server or you
local Internet Service Provider (ISP).  The important thing to remember is that
you can not publish you web page with out access to a Web Server.

Once you have access to a Web Server Netscape Composer provides you with
an easy interface for publishing your web pages, but before you use the publish
feature you must have several pieces of information.  Make sure you have the
information you need to publish you page.  You must know:

•  The FTP or HTTP address of the server that will be hosting your page.
•  Your Internet account name.
•  Your account password.

Call your Internet Service Provider or system administrator for the above
information.

1. Connect to the Internet as you normally do.

2. If it’s not already visible in the Composer window, open the page you
want to publish.

3. Click the Publish button on the Composition toolbar or
from the pull down menu, select File > Publish.  Either
way, the Publish Page dialog box will appear.

Section 8
Publishing Your Page
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4. In the Publish Files to This Location text box, type the address of the
Web Server where you are publish you page.

5. In the User Name text box, type the user name for you internet
account.

6. In the password text box, type your password.

7. Click the files associated with the page radio button to include any
image files your page uses.  Or click the all files in the page’s folder
radio button to include all the pages and image in that folder.

8. When you have all the information in the correct locations click OK.

9. When the Composer is finished uploading the files, the Publish Page
dialog box will close.

10. To see your page live on the Internet, go to Navigator and type in you
web page URL.

CONGRATULATIONS!
YOU NOW HAVE A WEB PAGE ON THE WEB!
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Credit is available in two forms: university credit from Southern Utah University
for recertification or inservice credit from the State Office of Education. To
receive credit, return the following assignment with in one month of final class
date to:

UEN Staff Development
201 Milton Bennion Hall
1705 Campus Central Drive
University of Utah
Salt Lake City, UT 84112-9250

or via fax at (801)585-9040. If you request State credit, your request will be
forwarded to the State Office of Education for final approval. If you request
university credit, an application form will be returned to you which you can fill out
and send back with the fee to SUU.  Forms must be returned by the following
deadlines: November 1st (fall semester), March 10th (spring semester), August 1st

(summer semester).

Name______________________ SS#_______________________

Address____________________ Class Title__________________

School_____________________ Date Attended_______________

District_____________________ Instructor __________________

Type of Credit: University (SUU) State Office
500 Level – Graded No Charge
$15.00/per credit

Assignment:
Create a web site using Netscape Composer.  Include in you web site:
•  5 pages that link together.
•  Use 2 different fonts in you text.
•  Use 2 different colors of text.
•  2 graphic on each page.

•  1 table.
•  Use 5 internal links, 3 external

links, and 1 email link.

Save you web site on a disk and mail it to the above address.  If you have
published you page on the web write the URL to the page you created on this
homework sheet and send it to the above address.

Now You Try It
Home Work
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Course Evaluation
Course Title
___________________________
Instructor
___________________________
Dates
___________________________

Please give both a numerical rating and an explanation. On numerical items, 1
means poor, 2 means fair, 3 means average, 4 means good, and 5 means very
strong.

Overall, how would you rate your course experience as compared to other
inservice you have received? 1 2 3 4 5
________________________________________________________________
________________________________________________________________
________________________________________________________________

Compared to other UEN Staff Development Training you’ve taken, how would
you rate this course?       1 2 3 4 5
________________________________________________________________
________________________________________________________________
________________________________________________________________

What was the best part of this class?
________________________________________________________________
________________________________________________________________
________________________________________________________________

List three ways this class could be improved.
________________________________________________________________
________________________________________________________________
________________________________________________________________

What should the course spend more time on or cover that it doesn’t?
________________________________________________________________
________________________________________________________________
________________________________________________________________

In terms of curriculum, what should the course spend less time on?
________________________________________________________________
________________________________________________________________
________________________________________________________________
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How would you rate the clarity of the curriculum?  1 2 3 4 5
________________________________________________________________
________________________________________________________________
________________________________________________________________

How would you rate the delivery of instruction?     1     2    3   4  5
________________________________________________________________
________________________________________________________________
________________________________________________________________

How would you rate the knowledge of your instructor/s? 1      2     3      4      5
________________________________________________________________
________________________________________________________________
________________________________________________________________

How would you rate the accessibility of instructors and level of personal
attention?   1 2 3 4 5
________________________________________________________________
________________________________________________________________
________________________________________________________________

How would you rate the manual quality?       1          2 3 4 5
________________________________________________________________
________________________________________________________________
________________________________________________________________

How would you rate the pace of instruction?   Too Fast       Good     Too Slow
________________________________________________________________
________________________________________________________________
________________________________________________________________

What will be your biggest obstacles to implementation of what you learned?
________________________________________________________________
________________________________________________________________
________________________________________________________________

Please rate your past experience with each of the following aspects of UEN
(leave an item blank if you have not experienced it)

Overall _____ Help Desk _____ Web Design ______
Training _____ Web Content_____ Installation Team _____
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